Order processing or creating fails: 'Order Numbering setup is incorrect'
Original Publishing Date:
2020-01-23
Symptoms
Orders are not processing in BSS, new orders cannot be placed. Depending on the affected order type the following error message appears in the BM.log in BSS:
Order Numbering setup is incorrect for Order Type PO (Payment Order)
Order Numbering setup is incorrect for Order Type RN (Renewal Order)
Cause
There are no more free numbers in the Enumerator Class of the affected order type. For example, the last successfully created Payment Order is PO999999 and the 'Last Doc Number' in the corresponding Enumerator Class is set to exactly the same value - PO999999.
So, all digits in the Enumerator Class are exceeded and BSS cannot create a new order since it cannot assign a unique number to it.
Such unique numbering is maintained per Vendor (Reseller). That means, different Resellers can have customer orders with the same Order Number, but Particular Reseller can not have orders on their level with the same number.
Resolution
Change the document numbering in the BSS Provider Control Panel for the affected order type:
- Go to System > Settings > More Finance Settings > Enumerator Classes.
- Click the appropriate order type.
- Change the Last Doc Number parameter - add more digits to the left part of the sequence, e.g. to resolve the problem described above one may set the 'Last Doc Number' to PO0999999 or PO00999999.
More details about the document numbering feature in BSS: Configuring Document Numbering.
Internal content